Symptoms:
- I added seats to my subscription, but my payment keeps failing. Why is this?
- I switched my subscription payment plan from monthly to prepaid, but the payment is now failing.
Cause:
Subscriptions purchased online using a credit card have a maximum payment limit. If you reach the transaction limit for your payment in your currency, the payment fails.
The current transaction limit for online credit card payments is as follows:
| Currency | Max |
|---|---|
| USD | $55,000 |
| EUR | €55,000 |
| JPY | ¥7,000,000 |
| KRW | ₩65,000,000 |
| BRL | R$300,000 |
Resolution:
If you believe that your payment is failing due to reaching the online transaction limit for credit card payments, you should purchase a new subscription under a different Unity organization and select ACH* as the payment option at checkout. After purchasing your new subscription, contact the Unity Customer Experience team or reach out to your Unity client partner for a cancellation.
*Note: ACH is only available to users whose Unity organization address is set in the US, who are based in the US, and who are paying in USD for over $5,000 worth of goods.
If you currency doesn't support ACH, contact the Unity Customer Experience team or reach out to your Unity client partner.