Symptoms
- I have a paid subscription and for invoicing purposes would like to add both my 'Bill To' and 'Ship To' details.
- I am making online purchases and need to add further billing details on my organization.
- The details on my invoice are incorrect as I need both my 'Bill To' and 'Ship To' details listed.
Causes
It may be that your credit card billing address is different to the information listed on your Company's Unity Organization details. It may also be that you recently changed your credit card and need to update the details on your Unity account.
Note: This procedure is for customers who can download invoices from Unity ID. |
Resolution
To add the 'BILL TO' details on your Organization, so that future invoices display this information, please follow these steps:
- Login to your Unity account at id.unity.com
- Click on the Organization to which your subscription is associated
- Click on the 'Payment Methods' tab
- Click the pencil icon beside your payment method
- Update your billing details
- Click the green 'Update' button
To add the 'SHIP TO' details on your Organization and invoice, so that future invoices display this information, please follow these steps:
- Login to your Unity account at id.unity.com
- Click on the Organization to which your subscription is attached
- Go to the 'Organization Details' section and click 'Edit'
- Enter your desired Ship to details
- Click the green 'Save' button
Note: If you download your invoices from the Unity Cloud Dashboard, please contact Customer Experience. When contacting us, please attach the following information to make it easier for us to respond.
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