Symptoms
- I have a paid subscription, and for invoicing purposes, I would like to add both my "bill-to" and "ship-to" details.
- I am making online purchases and need to add further billing details for my organization.
- The details on my invoice are incorrect, as I need both my "bill-to" and "ship-to" details listed.
Causes
Your credit card billing address may differ from the information listed on your company's Unity organization details. You may also have recently changed your credit card and need to update the details on your Unity account.
Note: This procedure is for customers who can download invoices from Unity ID, and the updated information can be only applied for future invoices. For security purposes, we are unable to update invoices that have already been generated. |
Resolution
To add the "bill-to" details on your organization, so that future invoices display this information, please follow these steps:
- Log in to your Unity account at id.unity.com
- Click on the organization to which your subscription is associated
- Click on the Payment Methods tab
- Click the pencil icon beside your payment method
- Update your billing details
- Click the green Update button
To add the "ship-to" details on your organization and invoice, so that future invoices display this information, please follow these steps:
- Log in to your Unity account at id.unity.com
- Click on the organization to which your subscription is attached
- Go to the Organization Details section and click Edit
- Enter your desired shipping details
- Click the green Save button
Note: If you download your invoices from the Unity Cloud Dashboard, please contact Customer Experience. When contacting us, please attach the following information to make it easier for us to respond.
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