Unity assigns a dedicated Partner Relations Manager (PRM) to organizations with qualifying Enterprise or Industry subscriptions or success plans. The PRM acts as an internal advocate, providing strategic advice, issue resolution, escalations, insider knowledge, and support coordination. They proactively contact eligible customers, with communication via email, video calls, or meetings. Customers without access can contact Unity Sales to explore options.
Symptoms:
- I have a Unity Enterprise or Industry license and see I have access to a Unity Partner Relations Manager. What does this mean?
- How do I access my Unity Partner Relations Manager?
- What benefits does a Partner Relations Manager provide?
Cause:
If your organization has any of the following, you are assigned a dedicated Unity Partner Relations Manager (PRM):
- Unity Enterprise subscription with 20+ seats
- Unity Industry subscription with 4+ seats
- Essential Success
- Integrated Success
Resolution:
Your Unity Partner Relations Manager(PRM) is your internal advocate, strategic advisor, and bridge to Unity. They work with you to drive issues from submission to resolution while maintaining clear lines of communication to keep you informed and productive.
PRMs can:
- Conduct regular check-ins and provide accelerated issue resolution
- Escalate your issues internally, from non-technical customer service queries related to licensing to technical issues that may need help from the relevant Subject Matter Experts in Unity.
- Share the latest insider knowledge, for example, product roadmaps and best practices to accelerate projects.
- Provide training coordination and support management with frequent and proactive communication.
Once you purchase an eligible license, your designated Partner Relations Manager will proactively reach out to your organization to introduce themselves and begin the partnership. No action is required on your part.
Communication with your Partner Relations Manager typically occurs via email, video calls, or in-person meetings, depending on your region and specific circumstances.
If you don't currently have access to a Partner Relations Manager but would benefit from dedicated support, please explore the following options based on your use case and contact our Sales team to discuss further:
- For Gaming customers: Learn more about Unity Enterprise
- For Industry customers: Learn more about Unity Industry