증상:
- 라이선스를 활성화할 수 없습니다.
- 라이선스 활성화를 시도할 때 왜 오류가 발생합니까?
- 라이선스를 확인하기 위해 인터넷에 연결하고 싶습니다.
- Unity Personal(=무료) 라이선스가 왜 활성화되지 않습니까?
원인:
활성화 오류는 일반적으로 컴퓨터와 Unity 서버 간 연결을 차단하는 네트워크 문제로 인해 발생합니다. 그러나 라이선스가 활성화되지 않는 다른 덜 흔한 원인도 있습니다. 예를 들어:
- 캐시 문제.
- 관리자 권한 부족.
- 새 라이선스 생성이 차단되는 오래된 라이선스 파일.
해결 방법:
허브 재시작
Unity Hub는 백그라운드 프로세스로 실행됩니다. 때때로 단순히 허브를 재시작하는 것만으로도 많은 라이선스 오류를 해결할 수 있습니다.
- 허브에서 로그아웃합니다.
- 작업 관리자(또는 강제 종료)를 사용하여 모든 Unity 프로세스를 종료합니다.
- 허브를 다시 실행하고 로그인하여 활성화합니다.
허브를 재시작한 후에도 활성화 오류가 계속 발생하면 아래의 추가 문제 해결 단계를 진행하세요.
네트워크 문제
네트워크 상에서 바이러스 백신 소프트웨어, 방화벽 또는 프록시와 같은 요소가 Unity 서버와의 연결을 차단하면 라이선스 활성화에 실패합니다.
먼저 방화벽/VPN을 비활성화하여 이것이 오류 원인인지 확인하세요. 다시 시도 버튼을 클릭한 후 라이선스가 활성화되면, 가장 간단한 해결책은 방화벽 또는 프록시를 다시 활성화하기 전에 다음 리소스에 대한 전체 도메인을 예외 목록에 추가하는 것입니다:
- unity.com
- unity3d.com
- plasticscm.com
- google.com
- googleapis.com
- microsoft.com
- aka.ms
서브도메인을 선택적으로 제어하려면, 프록시 예외 매뉴얼 페이지의 표에 있는 항목을 추가하세요.
컴퓨터 접근 권한 확인
강력하고 안정적인 인터넷 연결을 확인했음에도 라이선스 활성화 문제가 계속된다면, 컴퓨터 하드 드라이브에 변경 권한이 없어서 문제가 발생할 수 있습니다. 문제를 해결하려면 아래 단계를 따르세요:
- 작업 관리자 또는 유사한 도구를 사용하여 모든 허브 프로세스를 종료합니다.
- 허브 아이콘을 오른쪽 클릭 > 관리자 권한으로 실행합니다. (Mac에서 루트 권한을 활성화하는 방법은 https://support.apple.com/en-us/HT204012 참조)
- 기사 '라이선스를 어떻게 활성화하나요?'에 설명된 단계를 따라 다시 라이선스를 활성화해 보세요.
오래된 라이선스 파일 삭제
때때로 이전 라이선스 파일이 라이선스 재활성화 과정에서 제대로 제거되지 않아 새 라이선스 생성이 차단될 수 있습니다. 이를 해결하려면 아래 단계를 따르세요:
- 작업 관리자 또는 유사한 도구를 사용하여 모든 허브 프로세스를 종료합니다.
- 파일 탐색기를 사용하여 다음 위치로 이동하세요:
- Windows:C:ProgramData/Unity
- Mac:Library/Application Support/Unity -
.ULF또는.XML파일을 삭제하세요. - 기사 '라이선스를 어떻게 활성화하나요?'에 설명된 단계를 따라 다시 라이선스를 활성화해 보세요.
위 문제 해결 후에도 오류가 계속되면, 고객 경험 팀에 문의하고 아래 파일 위치에서 찾은 로그 파일을 함께 보내 추가 지원을 받으세요:
(파일이 숨김 처리된 경우, 보기 메뉴에서 숨긴 항목 표시를 선택하세요.)
허브 로그 파일 (info-log.json):
- Windows: C:\users\<yourusername>\AppData\Roaming\UnityHub\logs
- Mac: ~/Library/Application Support/UnityHub/logs
- Linux: ~/.config/UnityHub/logs
Unity.Licensing.Client:
- Windows:C:\users\<yourusername>\AppData\Local\Unity\Unity.Licensing.Client.log
- Mac: ~/Library/Logs/Unity/Unity.Licensing.Client.log
- Linux: ~/.config/unity3d/Unity/Unity.Licensing.Client.log