증상:
- Unity를
-serial <s> -username <u> -password <p>옵션과 함께 실행하면 동일한 PC에서 두 번 활성화됩니다. Unity 대시보드에서 두 개의 활성화가 관찰됩니다: 하나는 Serial 유형이고 다른 하나는 Entitlement 유형입니다.
내 Unity Hub에 두 개의 라이선스가 활성화된 것으로 표시됩니다.
원인:
Unity의 Industry, Enterprise 및 Pro 플랜은 이제 named-user licenses(NUL)라는 새로운 라이선스 시스템을 사용하며, 이 시스템은 시리얼 키가 필요하지 않습니다. 자세한 내용은 다음 지식 기반 문서를 참조하세요: Unity Industry/ Enterprise/ Pro 라이선스를 어떻게 활성화하거나 반환합니까?
귀하의 플랜이 NUL을 지원하므로 명령은 이전 시리얼 활성화와 새로운 권한 부여 활성화 방법(NUL)을 동시에 트리거합니다:
-
-username및-password인수는 새 Entitlement 활성화를 사용하여 로그인합니다. -
-serial인수는 이전 Serial 활성화 방법을 사용합니다.
해결 방법:
라이선스가 계정에 연결되어 있으므로 더 이상 명령줄에 시리얼 키를 포함할 필요가 없습니다. 방법은 다음과 같습니다:
- 계정에서 모든 활성화를 반환하여 새로 시작하세요. 자세한 내용은 다음 문서를 참조하세요 Pro/ Plus/ Enterprise 라이선스의 활성화를 어떻게 반환합니까?
- 기존 라이선스 파일로 인한 문제를 방지하려면 컴퓨터에서
Unity_lic.ulf파일을 삭제하세요.
파일 위치: Windows에서는C:\ProgramData\Unity\, Mac에서는Library\Application Support\Unity 명령줄에서 시리얼 키 인수를 제외하여 단순화하세요:
… -serial -username 'name@example.com' -password 'XXXXXXXXXXXXX'
추가 정보:
자세한 지침은 Unity 라이선스 관리에 관한 Unity 문서를 참조하세요: Unity License Management Documentation.