Symptoms:
- I no longer want to subscribe to Unity.
- I cannot afford my subscription payments.
- I have no use for my subscription anymore.
- I cancelled my Unity subscription but I'm still being charged.
Cause:
You may no longer wish to subscribe to a Unity service for a number of reasons such as unaffordability or loss of project funding.
Most Unity subscriptions have a 12 month commitment period. Turning off automatic renewal will not have an effect on your subscription until the commitment period is over.
Resolution:
If you have finished your commitment period (12 month contract):
Note that you must be the Owner of the Organization to complete this process.
- Sign in to your Unity ID
- Click Organizations to the left of the screen.
- Click on the Organization name you wish to manage.
- Click on the Manage button (cog icon) in the Subscriptions section.
- Click the Manage subscription tab and scroll down the page.
- Click the link that says I want to cancel auto-renewal.
- When you click the link, a pop-up window appears. Choose your reason for cancelling from the list provided. Click Continue.
- A final pop-up will appear giving you the option to contact Support. If you still wish to continue, click No thanks, I want to cancel.
If you have not finished your commitment period:
If you are still within your commitment period, you are obliged to make the monthly payments until this commitment period has ended. See your Terms and Conditions for details.
If you stop making payments for your subscription, Unity will suspend your account after 21 days; however, you will still be required to pay the full amount owing.
If you have further questions about subscription cancellation, please contact Support.
More Information:
See the Subscriptions FAQ for more information.
Comments
7 comments
there are no active subscriptions listed in the "Manage subscription" and no "I want to cancel my subscription." link.
Hi Light Echo,
To make changes to your subscription, you will need to have a payment method attached to your account.
When attached, you will be able to navigate to alter the renewal status of your account to off.
If you are having any further issues, please submit a ticket to our Customer Service team!
Hey! Anyone interested in addressing this, I’m going to put together a small class action lawsuit because this is a predatory contract. Ive already emailed a few journalists about unity targeting educators and struggling artists by offering free trial periods and giving them expensive year long contracts with deceptive language. Please email jjmyers@cps.edu.
Hi John,
Thank you for your message.
I am aware that you are already in discussions with my colleague in a ticket about your particular issue.
I can only reiterate that all of our subscriptions carry a 12 month commitment period once a trial is completed. We do allow users to terminate their trial within 30 days and not proceed with the subscription and the commitment period, this would be advised during the setup of your trial. From what I understand, we were not contact by yourself during this trial period which is why you are inside your commitment period.
If you do have any specific reasons as to why you no longer require this license, such as unaffordability, please reach out to us directly within your support ticket so we can look into this for you in more detail.
Don't/haven't used it outside of my trial. signed up for a trial (like any other) and when looking at the product pricing it doesn't mention 12 month contracts. Count me in on the class action. So incredibly infuriating and is taking money when you can clearly view my usage.
If your product was good, I don't think you'd be required to lock-in non-business users to make profit.
Thanks for nothing - aside from a waste of payments that I could be spending on my daughters future. Solid company.
Hi John, I have the same issue, and it's very frustrating. I'm also a researcher, at the MIT. I have emailed you; please count me in for your lawsuit.
Hi Stephen,
I am sorry to hear about your frustrations with regards to your subscription. From what I can see, we are already discussing this with you inside your support ticket so please continue posting within that so we can help you with your situation.
If any other users do have issues with cancelling their subscriptions, please do not hesitate to contact us via our ticket form here.
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