Symptoms:
- I have set up a Unity Pro, Plus or Enterprise subscription with an annual payment plan and would like to change to monthly payments.
- I would like to change my subscription payment plan.
Cause:
If you have purchased a one year, paid monthly Unity Pro, Plus or Enterprise subscription, you can prepay the rest of your commitment period.
However, if you have a one year, prepaid Unity Pro, Plus or Enterprise subscription, you cannot change to a monthly payment plan during your 12 month commitment period. Having said that, you can schedule how your subscription will renew at the end of your contracted term.
Resolution:
If you have a one year, paid monthly subscription and would like to prepay the rest of your 12 month commitment period, follow the steps below:
- Sign in to your Unity ID at id.unity.com.
- Click 'Organizations' to the left of the screen.
- Click on the Organization with your one year, paid monthly subscription attached.
- Click the cog icon to the right of your subscription.
- Click the 'Manage Subscription' tab.
- Find the "Subscription progress" blue bar and click the "Pay for remaining period" button.
- You will see a page that confirms the amount owed to pay for the rest of your commitment period and the card details for your payment card. If all is well, click the "Confirm" button to proceed.
More Information:
For the full steps on renewing your subscription, please see the article 'How do I renew my subscription?'.
For more information on all Unity subscription plans, please go to the our Store page.
Comments
1 comment
Users should definitely get an option to change the payment plan on their current subscription. Very unhelpful.
Please sign in to leave a comment.