Symptoms:
- When I open the Hub, I see a message that says I have no active licenses.
- I want to activate my personal license.
Cause:
Unity Personal users need to ensure that they connect to the internet before the 30-day offline grace period. If you have not been online for 30 days, when you open the Hub, you will see a notification that you need to connect to the internet to confirm your license.
Resolution:
To activate or refresh your Unity Personal (free) license, see the steps below:
Note: To activate a Unity Plus, Pro, Enterprise, or Industry license, see the article, 'How do I activate my license?'. |
- Launch the Unity Hub.
- Select Manage licenses.
- Click Refresh.
- Review the Editor Software Terms, and select Agree.
- Your Personal License is now activated.
Alternatively, you can sign out and back into your Unity ID to refresh your license:
- Launch the Unity Hub.
-
Select the dropdown menu by your initials.
-
Select Sign out.
- Click the Sign in button.
You now have an active Personal License. If your license will not activate after following the above steps, try restarting the Hub.
- Sign out of the Hub.
- Close all Unity processes using your task manager, (or force quit).
- Relaunch the Hub and sign in to activate.
If you continue to see an activation error after restarting the Hub, contact Customer Experience with your Hub log file so we can look closer at your issue.