Symptoms:
- I have subscribed to Unity but Unity Cloud does not reflect the right access
- I am seeing Unity Cloud Personal instead of my Unity Pro license
- Unity Cloud fails to recognize an existing Unity Pro subscription
- Unity Cloud does not reflect the correct subscription status
Cause:
Users who purchased Unity Pro before the launch of the Unity Cloud platform will find that their licenses are not visible at cloud.unity.com as your subscription is hosted at id.unity.com
Resolution:
If you purchased a Unity Pro subscription before the Unity Cloud platform launch, follow these steps to manage your subscription:
- Log in to https://id.unity.com
- Navigate to "Organizations" in the left panel menu
- Select your organization to manage it
- Click on "Subscriptions and Services"
- View and manage your active subscriptions
This process will allow you to confirm your Unity Pro subscription status and ensure it's properly linked to your account.
More information:
I purchased a subscription but cannot find it on my account