To remove a member no longer working with your organization, only Owners and Managers have permission to do so. Navigate to your organization's page on Unity Cloud, select Members, click the three dots next to the user, and choose "Remove from organization," then confirm by clicking Delete. Note that Billable Owners cannot be removed unless their role is reassigned.
Cause:
If a member of your organization is no longer employed by your company, you may need to remove them from your organization for privacy or security reasons.
Resolution:
Only Owners and Managers have permission to remove members from an organization.
To remove a member from your organization, follow the steps below:
- Navigate to https://cloud.unity.com/account/my-organizations and select the organization you want to manage.
- Select Members from the left side menu.
- Click on the three dots (...) at the right side of the name of the user you want to remove.
- Select the option Remove from organization.
- Click the red Delete button.
The user has now been removed and will no longer have access to view the organization's data.
Please note that Billable Owners of an organization cannot be removed unless their role has been assigned to another user. To learn more about changing the Billable Owner, see the article, How do I change the Owner of my Organization?