Symptoms:
- I need to remove a member of my organization who is no longer working with us.
Cause:
If a member of your organization no longer works for your company, you may need to remove them from your organization for privacy or security reasons.
Resolution:
Only Owners and Managers have permission to remove members from an organization.
To remove a member from your organization, follow the steps below:
- Sign into your Unity ID at id.unity.com.
- Click Organizations on the left side of the screen.
- Select the Organization you want to edit, either by clicking the Manage (cog icon) or the name itself.
- Click Members & Groups to the left side of the screen. Alternatively, click on See all further down the page.
- Click the X to the right of the user you want to remove.
- Click the red Remove button in the following pop-out.
The user has now been removed and will no longer have access to view the organization's data.
Please note that Billable Owners of an organization cannot be removed unless their role has been assigned to another user. To learn more about changing the Billable Owner, see the article, How do I change the Owner of my Organization?
If you are experiencing problems removing a member of your organization, you can submit a support request so that our team can help.
More Information: