Symptoms:
- I haven’t used Unity before and want to know how to activate my license.
- I want to manually activate a Plus, Pro, or Enterprise license but the Unity Hub isn’t letting me do it.
- My project isn’t launching.
- I see an error during the online activation process.
Cause:
If you aren’t able to activate your Unity license online, the Unity Editor won't open.
For example, if your internet connection is interrupted, or if you use a closed network, the online activation will fail.
Resolution:
Unity Personal Plan users:
Manual activation is not available for Unity Personal users. If you need to activate your license offline, a Unity Pro subscription needs to be purchased. See the Unity store page for more information.
Plus, Pro, and Unity Student users:
If you cannot activate your Unity license online, or you receive errors during the regular activation process, the usual workaround is to activate offline (manual activation).
To manually activate your Unity Editor license, follow these steps:
- Launch the Unity Hub.
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Select the account icon in the top left of the window and log in to your Unity ID.
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Select Preferences (cog icon) in the top left of the window.
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Select Licenses in the left menu.
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Click Add.
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Select Activate with license request.
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Select Create license request and save the file to the chosen location on your computer, such as your desktop.
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Click the license.unity3d.com/manual link to open the manual activation page.
- If prompted, log in with your Unity ID.
- On the Manual activation page, click Browse and select the license request file from the location you saved it in step seven.
- Click Next.
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Enter your serial number and click Next.
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Click Download license file and save the .ulf file to your computer.
- Open the Unity Hub’s How to activate an existing license window (Preferences > Licenses > Add > Activate with license file).
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Select the folder icon to open your machine file browser.
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Select the .ulf license file saved in step 13 and click Open or Select file.
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Click Activate.
Your Unity license is now activated.
More Information:
Note: Unity Plus is no longer available to purchase. |
If you encounter any problems during the activation process, contact Customer Experience detailing the steps taken, screenshots of any errors you encountered, and the license serial key used, and we will do our best to help.
If you receive the error “Your serial number is not valid”, you might have to return a previous activation.
Refer to the article, How do I return the activations on my Pro/ Plus/ Enterprise license?
Related Articles:
How do I return the activations on my Pro/ Plus/ Enterprise license?
Comments
20 comments
That didn't help, the unity hub problem says that there's a problem activating a new personal license. Yes: I am logged. Yes, I have internet conection. Yes, I refreshed
Help. Unity Hub problem activation license/
Hello emanuel guilherme and OOOO,
Thank you both for your comments. I am sorry to hear you are both experiencing some problems activating your license with the Hub.
The comments section is not the best place to try and solve these issues, so I will create a ticket for each of you and reach out to you shortly via email.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
I've tried this and i got this error; "Unable to save license". Cant figure it out
the same problem, unable to save license
Exactly :(
Hello. this guide is for older versions of unity hub. i cant see the MANUAL ACTIVATION option in the license management section...
Same here
yup same
Hello all,
I am sorry to hear that you are all experiencing some issues activating in the Unity Hub. This is certainly not the experience that we would wish any of our users to have.
In order to help you get this resolved, I would advise emailing us directly at support@unity3d.com or alternatively, you can submit a ticket via this web form.
These kinds of things are solved much easier via email where we can offer detailed troubleshooting advice.
We look forward to hearing from you soon to get this resolved!
None of these worked. Including the manual activation and command line activation. This is just sad.
When I click on my project in unity hub it says My project could not be opened. Please check the logs. what should i do
The frustration to make unity play nice. Mine was a mess to activate .Unity hub would reject it over and over even if it’s downloaded (the license key) also it would not request one like the guy says so that didn’t help. I had to quit and then restart the hub. To even see it take a key. Support is ok but they seem to email when a person is at work so kinda way too late bummer overall it was the signal which is weird cause it says I’m signed in and my assets load no problem but to activate a key is a somewhat a challenge cause of the net but even to play any game on WiFi takes a certain amount of download speeds I think at least 14 and yes it was the signal or maybe a unknown ip address .Find a compatible version, maybe relaunch the desktop finder
so what is the solution????😐😕🤔
yes! What is the solution?
I put the license key and then quit the hub and restarted it and it had the key in it
But HOW to put
?
Even with the key downloaded It didn’t work. none of them did.( it should take the key in preference/license/Add/Activate with serial number ) in the hub I put the key in and quit the hub and restarted it and I checked to add the key and it added it, might have to try once or twice
Hello all,
Thank you for your comments regarding license activations. I am sorry to hear that you are having some issues getting up and running.
The best thing to do in this scenario is to reach out to our Customer Experience Team directly, so that we can help you to troubleshoot your activation issues directly. Unfortunately it can be tricky to advise on these things in the comments section, as I am sure you can understand.
Please email us at support@unity3d.com or alternatively, submit a ticket via this web form.
I hope this helps!
I found a solution.
I reinstalled the system (windows).
The problem was that I was working in this system with a ENTERPRISE account. Then I removed Unity HUB and tried to sign up for a FREE account. Apparently some tails remained in the registry. In short, I had to completely remove the system and reinstall everything again. Then and only then does everything work.
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