Symptoms:
- I have not used Unity before and want to know how to activate my license.
- I want to activate a Personal, Plus, Pro, or Enterprise license but the system is not letting me do it.
- My project is not launching.
- I see an error during the online activation process.
Cause:
If you are not able to activate your Unity license online, the Editor won't open.
The online activation process can be interrupted by using a closed network or by having a weak/ intermittent internet connection, for example.
Resolution:
If you cannot activate your Unity license online, or you receive errors during the regular activation process, the usual workaround is to activate offline (manual activation).
To manually activate your license, please follow the steps below:
- Launch the Unity Hub.
- Click the account icon in the top left of the window to log in to your Unity ID.
- Click Preferences (cog icon) in the top left of the window.
- Click Licenses to the left of the window.
- Click the blue Add button.
- Click Activate with license request.
- Click Create license request and save the file to the chosen location on your machine. (We recommend a simple location like your desktop).
- Click the link indicated to open the manual activation page.
- On the Manual activation page, click Browse and select the license request file from the location you saved it in step seven > click Next.
- Select whether you have a Unity Plus or Pro or Unity Personal Edition license.
- If using a Unity Plus or Pro license, enter your serial number and click Next.
- If using Unity Personal Edition, select which option applies to you and click Next.
- Click Download license file and save the .ulf file to your machine.
- Open the Hub, proceed to the Activate with license file section in the How to activate an existing license window, and then load the license file (.ulf) from the location you saved this in the previous step by clicking on the folder icon.
- Select the .ulf license file and click Open or Select file.
- Click Activate to load the license file.
Your Unity license is now activated.
More Information:
If you encounter any problems, please reach out to Customer Experience detailing the steps taken, including screenshots of any errors you encountered if possible.
If you receive the error 'Your serial number is not valid' you may need to return a previous activation. See the article 'How do I return the activations on my Pro/ Plus/ Enterprise license?'
Related Articles:
Comments
20 comments
That didn't help, the unity hub problem says that there's a problem activating a new personal license. Yes: I am logged. Yes, I have internet conection. Yes, I refreshed
Help. Unity Hub problem activation license/
Hello emanuel guilherme and OOOO,
Thank you both for your comments. I am sorry to hear you are both experiencing some problems activating your license with the Hub.
The comments section is not the best place to try and solve these issues, so I will create a ticket for each of you and reach out to you shortly via email.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
I've tried this and i got this error; "Unable to save license". Cant figure it out
the same problem, unable to save license
Exactly :(
Hello. this guide is for older versions of unity hub. i cant see the MANUAL ACTIVATION option in the license management section...
Same here
yup same
Hello all,
I am sorry to hear that you are all experiencing some issues activating in the Unity Hub. This is certainly not the experience that we would wish any of our users to have.
In order to help you get this resolved, I would advise emailing us directly at support@unity3d.com or alternatively, you can submit a ticket via this web form.
These kinds of things are solved much easier via email where we can offer detailed troubleshooting advice.
We look forward to hearing from you soon to get this resolved!
None of these worked. Including the manual activation and command line activation. This is just sad.
When I click on my project in unity hub it says My project could not be opened. Please check the logs. what should i do
The frustration to make unity play nice. Mine was a mess to activate .Unity hub would reject it over and over even if it’s downloaded (the license key) also it would not request one like the guy says so that didn’t help. I had to quit and then restart the hub. To even see it take a key. Support is ok but they seem to email when a person is at work so kinda way too late bummer overall it was the signal which is weird cause it says I’m signed in and my assets load no problem but to activate a key is a somewhat a challenge cause of the net but even to play any game on WiFi takes a certain amount of download speeds I think at least 14 and yes it was the signal or maybe a unknown ip address .Find a compatible version, maybe relaunch the desktop finder
so what is the solution????😐😕🤔
yes! What is the solution?
I put the license key and then quit the hub and restarted it and it had the key in it
But HOW to put
?
Even with the key downloaded It didn’t work. none of them did.( it should take the key in preference/license/Add/Activate with serial number ) in the hub I put the key in and quit the hub and restarted it and I checked to add the key and it added it, might have to try once or twice
Hello all,
Thank you for your comments regarding license activations. I am sorry to hear that you are having some issues getting up and running.
The best thing to do in this scenario is to reach out to our Customer Experience Team directly, so that we can help you to troubleshoot your activation issues directly. Unfortunately it can be tricky to advise on these things in the comments section, as I am sure you can understand.
Please email us at support@unity3d.com or alternatively, submit a ticket via this web form.
I hope this helps!
I found a solution.
I reinstalled the system (windows).
The problem was that I was working in this system with a ENTERPRISE account. Then I removed Unity HUB and tried to sign up for a FREE account. Apparently some tails remained in the registry. In short, I had to completely remove the system and reinstall everything again. Then and only then does everything work.
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