症状:
- ライセンスを有効化できません。
- ライセンスを有効化しようとするとなぜエラーが表示されるのですか?
- ライセンスを確認するためにインターネットに接続したいです。
- なぜUnity Personal(無料)ライセンスが有効化されないのですか?
原因:
有効化エラーは一般的に、マシンとUnityサーバー間の接続をブロックするネットワークの問題が原因です。ただし、他にもまれに以下のような原因でライセンスが有効化されないことがあります:
- キャッシュの問題。
- 管理者権限の不足。
- 新しいライセンスの作成を妨げる古いライセンスファイル。
解決策:
Hubを再起動する
Unity Hubはバックグラウンドプロセスとして動作しています。時には、Hubを単純に再起動するだけで多くのライセンスエラーが解決することがあります。
- Hubからサインアウトします。
- タスクマネージャーを使用してすべてのUnityプロセスを終了するか、強制終了します。
- Hubを再起動してサインインし、有効化を試みます。
Hubを再起動しても有効化エラーが続く場合は、以下のトラブルシューティング手順を続けてください。
ネットワークの問題
ネットワーク上でUnityサーバーへの接続をブロックしているもの(例えば、アンチウイルスソフト、ファイアウォール、プロキシ)があると、ライセンスの有効化に失敗します。
まず、ファイアウォールやVPNを無効にして、これがエラーの原因かどうかを確認してください。再試行ボタンをクリックしてライセンスの有効化ができる場合は、最も簡単な解決策として、ファイアウォールやプロキシを再度有効にする前に以下のドメイン全体を例外リストに追加してください:
- unity.com
- unity3d.com
- plasticscm.com
- google.com
- googleapis.com
- microsoft.com
- aka.ms
サブドメインを選択的に制御したい場合は、プロキシ例外マニュアルページの表から項目を追加してください。
関連情報: Webプロキシ経由でのUnityの使用
マシンのアクセス権限を確認する
強力で安定したインターネット接続を確認した後もライセンスの有効化に問題がある場合、マシンのハードドライブへの変更権限が不足している可能性があります。問題を解決するには、以下の手順に従ってください:
- タスクマネージャーなどを使用してすべてのHubプロセスを終了します。
- Hubアイコンを右クリックし、管理者として実行を選択します。(Macでのroot権限の有効化については、https://support.apple.com/en-us/HT204012を参照してください。)
- 記事「ライセンスを有効化するには?」に記載された手順に従い、再度ライセンスの有効化を試みます。
古いライセンスファイルを削除する
ライセンスの再有効化時に、以前のライセンスファイルが正しく削除されないことがあります。この古いライセンスファイルが新しいファイルの作成を妨げることがあります。これを解決するには、以下の手順を実行してください:
- タスクマネージャーなどを使用してすべてのHubプロセスを終了します。
- ファイルブラウザを使用して以下の場所に移動します。
- Windows:C:ProgramData/Unity
- Mac:Library/Application Support/Unity - そこにある
.ULFまたは.XMLファイルを削除します。 - 記事「ライセンスを有効化するには?」に記載された手順に従い、再度ライセンスの有効化を試みます。
上記のトラブルシューティングを行ってもエラーが続く場合は、カスタマーエクスペリエンスチームに連絡し、以下のファイル場所にあるログファイルを提供してさらなるサポートを受けてください:
(ファイルが隠されている場合は、「表示」から「隠しファイル」にチェックを入れてください。)
Hubログファイル (info-log.json):
- Windows: C:\users\<yourusername>\AppData\Roaming\UnityHub\logs
- Mac: ~/Library/Application Support/UnityHub/logs
- Linux: ~/.config/UnityHub/logs
Unity.Licensing.Client:
- Windows:C:\users\<yourusername>\AppData\Local\Unity\Unity.Licensing.Client.log
- Mac: ~/Library/Logs/Unity/Unity.Licensing.Client.log
- Linux: ~/.config/unity3d/Unity/Unity.Licensing.Client.log