この記事は、以下に該当するお客様向けのご案内です。
- Unity Hub 経由でライセンス認証を行いたい。しかし、エラーが表示されます。
- 私のシリアル番号/ライセンスキーがアクティベートされません。
- Unity を使用しようとすると、「シリアル番号は無効です」というエラーメッセージが表示されます。
- 「シリアル番号がライセンス認証の上限に達しています」というエラーメッセージが表示されます。
- 「あなたのシリアル番号は無効です」というエラーメッセージが表示されます。
- Unity Editor にアクセスしたいのですが、Hub でエラーが表示されます。
- Hub で「シリアルキーが無効です」と表示されています。
原因:
このエラーは、ライセンスキーのアクティベーション数が上限に達していることや、最近 OS をアップデートしたりすると発生します。Unity ライセンスファイル(.ULF)が参照しているハードウェア ID が変更され、現在のライセンスファイルが無効になってしまうことがあります。
また、「シリアル番号が無効です」というエラーのもう一つの原因は、お使いのマシンと Unity ライセンスサーバー間の接続の問題です。
以前のライセンスファイルが新しいライセンスファイルの作成をブロックしています。
解決策:
Unity Editor のバージョン 4.5 以降で行われたアクティベーションは、Unity ID から返却することができます。返却方法については、以下の記事をご確認ください。
上記のプロセスを完了してもエラーが発生する場合は、お使いのマシンとライセンスサーバー間の接続に問題がある可能性があります。この場合、ファイアウォールやプロキシの設定を確認し、URL をホワイトリストに登録し、ウィルス対策ソフトを無効にしてください。
それが難しい場合や失敗する場合は、手動でのアクティベーションをご検討ください。手動でのライセンスアクティベーション
アクティベーションを解除し、接続を確認してもライセンスのアクティベーションができない場合は、お使いのマシンに保存されているライセンスファイルに問題がある可能性があります。既存のライセンスファイルを削除して、新しいライセンスファイルを作成する必要があります:
- タスクマネージャーなどを使用し、Hub を完全に閉じてください。
- ファイルエクスプローラーを使用して、次の場所に移動します;
- Windows: C:\ProgramData\Unity
- Mac: Library/Application Support/Unity
そして、そこに格納されている .ulf ファイルを削除します。 - Hub を再度起動し、Hub が該当のハードディスクにフルアクセス権限が与えられているか確認してください。
- 以下の記事に記載されている手順に従って、ライセンスを再認証します。
- ライセンスをアクティベーションするにはどうすればいいですか?
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