Symptoms:
- I want to leave an organization and give ownership to another user.
- I want to become the organization owner.
- I need to add another owner to my organization
- I need to take full ownership of a Unity organization
Cause:
Owners can access all settings in their organization's subscriptions across all projects. They are the only users with access to the organization's payment instruments, subscription invoices, and billing information. They can also assign seats, set organization roles, and enable Unity services.
Resolution:
The process differs depending on the type of owner role to assign.
There are two types of owners in a Unity organization: Regular and Billable owners:
- Regular Owner: Has administrative rights over the organization. They can access most settings in any of their organization's subscriptions across all projects. They have access to subscription invoices. They can also assign seats, set organization roles, and enable Unity services.
- Billable Owner: This is a specific role assigned to the individual responsible for all billing-related matters within the organization. This includes managing payment methods, overseeing subscription renewals, and handling invoice settlements.
Note: By default, an organization's creator is assigned as the billable owner of the organization. |
Assigning a "Regular owner" role:
Any organization owner can make this change. First, they must ensure that the user is already a member of the organization. If they need to invite the Unity account, they can follow the steps in the article' How do I invite a new member to my Organization?'
After the user joins the organization, the organization owner can assign the appropriate role as outlined in the article How do I assign roles to members as an organization owner?
Assigning a "Billable owner" role:
This is a common situation when a former employee leaves a company and another user needs to take ownership of the organization to manage subscriptions and billing. In this case, please submit a support request.
Note: Unity will require evidence that the organization owner has left the company. |
Other common scenarios where you may need to submit a support request:
- You cannot remove the previous owner of the organization.
- You cannot leave a Unity organization you had previously created.
- The owner has left your company, and no other members hold owner roles in the organization.
- The owner has left your company, and the organization where you need to change ownership is their default organization.
More information:
What can Owners, Managers, Users, and Guests do in an organization?