Symptoms:
- I have spelled my username incorrectly.
- I want to change my username on my Discussions profile/ Asset Store.
- My username is outdated, and I want to update it.
Cause:
There could be several reasons to change your username in your Unity account. For example, you have just created an account and realized that your username choice was wrong, or perhaps, your name or company name is outdated.
Resolution:
You can modify or change your username yourself, providing that another Unity user has not already taken the name.
To change your username, follow the process below:
- Navigate to https://cloud.unity.com/account/account-settings and sign in if prompted.
- Click the pencil icon to the right of the username section.
- Enter your new username and click Save. You will be asked for an alternative username if the one you have entered is already taken by another user.
After the above steps, your username will automatically update. If the change does not show immediately on Discussions or The Asset Store, try signing out and back to sync all of the accounts with the same username.
Note: If your username on Discussions or the Asset Store has not been updated, after signing out and waiting 24 hours, contact Unity Customer Experience. |
More Information:
If you would prefer to use the legacy ID portal, you can find the steps for updating your username in the article here.
How do I change the email address attached to my Unity Account?
How do I permanently delete my Unity account