Symptoms:
- I have not received my confirmation email.
- I cannot log into my newly created account.
- I see an invalid email address error.
- The system does not recognize my email address.
Cause:
We all occasionally make mistakes when creating an online account.
Sometimes, 'Gmail' is misspelled as 'email,' which is far more common than you might think. This means that we cannot send out your confirmation email, which prevents you from being able to confirm your account and use Unity.
Resolution:
The best thing to do is to create a new account with the correct email address and an alternative username.
This will lead you to create your Unity account with the correct e-mail address.
If you need any help or further support, please contact Unity Customer Experience team.
More Information:
How do I change the email address attached to my Unity Account?
How do I permanently delete my Unity account?