Symptoms
- I have not used Unity before and would like to know how to activate my license
- I would like to activate Personal, Plus, or Pro
- I have used Unity Personal, but would like to update the Editor to my new Plus or Pro license.
Cause
Once you have assigned the license seat to yourself or another user in your Organization,
there are a couple of ways to activate, depending on your network situation.
Resolution
The fastest way to activate your license is online. To do this, follow the steps below:
- Open the Unity Hub
- Log into your Unity ID via the account icon in the top right of the window.
- Once signed in, click the cog icon.
- Click ‘License Management’ to the left of the window.
- Click the blue ‘Activate New License’ button and input your new License key.
For more detailed guidance and screenshots please visit our documentation page here.
If you have used Unity Personal, or a different Pro/Plus license key, in the past you need to update your Editor to input your new license details.
To do so, follow the steps below:
- When inside the Editor, click the 'Unity' button if you’re on a Mac machine or 'Help' if you are on a Windows machine.
- Click 'Manage License'
This will redirect you to The Hub to follow the Online Activation process as outlined above.
If you are in a secure network environment, or receive an error whilst activating, it may be due to a connectivity problem.
Please try manually activating, carefully following the steps outlined in our documentation here.
If this does not work for you, please send the details along with screenshots of any errors received to Customer Service.
More Information
Comments
20 comments
This is not working anymore.
I've been fighting with mine for a few hours tonight and I finally got it to work by deleting my license files (*.ulf) in C:\ProgramData\Unity
Then restarting Unity and it asks you to activate your local copy again.
Hi there,
The process is still working from my testing just now. As Mike has said, any old license files may cause this process to not work so clearing out any pre-existing license files before completing this process may resolve any issues you have.
If you still get any issues, please don't hesitate to raise a support ticket.
I downloaded Unity with a personal account and it never gave any chance to activate it. It directly tries to authenticate the license then errors... I tried multiple things nothing is working.
I'm on a Plus license yet license activation is a never-ending issue. Almost every time I open Unity I have to re-activate, enter the serial and it says it's reached a maximum number. Then I close it, open again and sometimes it works, sometimes it doesn't. I think there are some really serious issues here and it's very frustrating.
Hi both,
I am very sorry to hear about the issues you are having.
It sounds like something might be up with your accounts - please don't hesitate to make a support ticket via the link here and we'll be more than happy to help you with your issues.
I have unity 5.3.4p3 version ,ca I buy plus or pro for this version ?
Hi Shahin,
Unfortunately, we do not sell licenses for specific versions. If you would like to use this version, the current subscriptions we have on offer do work with earlier versions, as an active subscription lets you use whichever version of Unity you wish.
Greetings. Seems like Unity Hub doesnt seem to update my license which i just bought today to the unity editors at all.
All of a sudden my Pro license won't activate. Had Unity on two machines activated with the same license. Reinstalled Windows on one, reinstalled Unity. Tried to put the key back in to the reinstalled Unity. Now everything is messed up on both instances of Unity...
I recall having issues before. Why is this so difficult?
Hi Rick,
My apologies you are having issue activating the license on your machines.
Please follow the steps in the following article to return both the activations:
https://support.unity3d.com/hc/en-us/articles/205056069-How-do-I-return-the-activations-on-my-Pro-Plus-license-
Once you have return the activations, you can activate your license again.
Is this company still in business? I don't see how after trying to activate for a couple of hours and finding the comments replete with others in the same boat. Looks like a cool pro
duct on utube and would be willing to pay some for it if there wasn't all the BS.
I am new to unity and for the life of me I cannot get the app to work. It keeps bringing me into the Unity Hub, and tells me I have no valid license. It will not let me log in and I cannot get it to work. So far this app is the worst.
How to use this License Key for Unity 3D?.
How to use this License Key for Unity 3D?.
Michael and Mike,
Sorry to hear you have had some problems activating!
I can that this was a little while ago, but if you still want help getting set up, please reach out to our Customer Service team. They will be happy to advise you on the problems you are encountering in the activation process.
You can contact them here!
Software Creative,
It sounds as if you have a specific serial key to activate. When you go through the activation process listed above, you will have the option to input you Plus or Pro serial key!
If you are having problems with this, please send a request through to our Customer Service team, who can help! If you can, include some screenshots and this should help them to diagnose the issue as quick as possible!
My Plus license doesn´t let me choose the dark theme or any other plus features.
I reactivated several times on HUB but nothing happens.
Please, help.
i fix this problem here https://youtu.be/szKRkdlPVuQ
I am having the same problem. My personal license does not work.
Please sign in to leave a comment.