Symptoms:
- How do I activate the Hub?
- How do I activate Unity?
- I have not used Unity before and want to know how to activate my license.
- I want to activate a Personal, Plus, Pro, Student, or Enterprise license.
- I have used Unity Personal but I would like to update to my new Unity Plus, Pro, Student, or Enterprise license.
Cause:
After you have assigned the license seat to yourself or another user in your organization (for Plus, Pro, Student, and Enterprise only), there are a couple of ways to activate your license depending on your network situation.
If you do not have a Unity license activated, projects will not open.
If you have recently updated your OS or changed any hardware, your machine's hardware ID (HWID) can make the current Unity License File (.ULF) redundant. You need to reactivate your license on the same device to use Unity.
Resolution:
Online activation steps:
- Launch the Unity Hub.
- Click the account icon in the top left of the window and sign in to your Unity ID.
- After you are signed in, click Preferences (cog icon).
- Click Licenses > Add license.
- Unity Plus, Pro, Student, and Enterprise subscription holders click Activate with serial number (i). Unity Personal (free) users click Get a free personal license (ii).
(i) For Plus, Pro, Student and Enterprise subscription holders, enter your serial number and click Activate license.
(ii) Unity Personal (free) users, read the Terms of Service, click Agree and get personal edition license.
Your license is now activated. Not working? See the troubleshooting steps below.
Troubleshooting
If you are in a secure network environment or receive an error while activating, it may be a connectivity problem.
In this case, try manually activating, carefully following the steps outlined in the Manual Activation Guide or the Knowledge Base article, 'How can I manually activate my license inside the hub?'.
If you receive the error 'Your serial number is not valid,' you may need to return a previous activation. See the article 'How do I return the activations on my Pro/ Plus/ Enterprise license?' & clear your existing license file by following the below steps:
- Close the Hub completely using the task manager (or similar).
- Using your file explorer, navigate to:
* Windows:C:ProgramData/Unity
* Mac:Library/Application Support/Unity
and delete the .ulf file housed there. - Launch the Hub again, ensuring you allow the Hub to make changes to your hard drive in the process.
- Reactivate your license following the steps outlined in the above article.
If this does not work for you, send your log files and screenshots of any errors received to the Customer Experience team.
More Information:
Note: Unity Plus is no longer available to purchase. |
Comments
33 comments
This is not working anymore.
I've been fighting with mine for a few hours tonight and I finally got it to work by deleting my license files (*.ulf) in C:\ProgramData\Unity
Then restarting Unity and it asks you to activate your local copy again.
Hi there,
The process is still working from my testing just now. As Mike has said, any old license files may cause this process to not work so clearing out any pre-existing license files before completing this process may resolve any issues you have.
If you still get any issues, please don't hesitate to raise a support ticket.
I downloaded Unity with a personal account and it never gave any chance to activate it. It directly tries to authenticate the license then errors... I tried multiple things nothing is working.
I'm on a Plus license yet license activation is a never-ending issue. Almost every time I open Unity I have to re-activate, enter the serial and it says it's reached a maximum number. Then I close it, open again and sometimes it works, sometimes it doesn't. I think there are some really serious issues here and it's very frustrating.
Hi both,
I am very sorry to hear about the issues you are having.
It sounds like something might be up with your accounts - please don't hesitate to make a support ticket via the link here and we'll be more than happy to help you with your issues.
I have unity 5.3.4p3 version ,ca I buy plus or pro for this version ?
Hi Shahin,
Unfortunately, we do not sell licenses for specific versions. If you would like to use this version, the current subscriptions we have on offer do work with earlier versions, as an active subscription lets you use whichever version of Unity you wish.
Greetings. Seems like Unity Hub doesnt seem to update my license which i just bought today to the unity editors at all.
All of a sudden my Pro license won't activate. Had Unity on two machines activated with the same license. Reinstalled Windows on one, reinstalled Unity. Tried to put the key back in to the reinstalled Unity. Now everything is messed up on both instances of Unity...
I recall having issues before. Why is this so difficult?
Hi Rick,
My apologies you are having issue activating the license on your machines.
Please follow the steps in the following article to return both the activations:
https://support.unity3d.com/hc/en-us/articles/205056069-How-do-I-return-the-activations-on-my-Pro-Plus-license-
Once you have return the activations, you can activate your license again.
Is this company still in business? I don't see how after trying to activate for a couple of hours and finding the comments replete with others in the same boat. Looks like a cool pro
duct on utube and would be willing to pay some for it if there wasn't all the BS.
I am new to unity and for the life of me I cannot get the app to work. It keeps bringing me into the Unity Hub, and tells me I have no valid license. It will not let me log in and I cannot get it to work. So far this app is the worst.
How to use this License Key for Unity 3D?.
How to use this License Key for Unity 3D?.
Michael and Mike,
Sorry to hear you have had some problems activating!
I can that this was a little while ago, but if you still want help getting set up, please reach out to our Customer Service team. They will be happy to advise you on the problems you are encountering in the activation process.
You can contact them here!
Software Creative,
It sounds as if you have a specific serial key to activate. When you go through the activation process listed above, you will have the option to input you Plus or Pro serial key!
If you are having problems with this, please send a request through to our Customer Service team, who can help! If you can, include some screenshots and this should help them to diagnose the issue as quick as possible!
My Plus license doesn´t let me choose the dark theme or any other plus features.
I reactivated several times on HUB but nothing happens.
Please, help.
Problem fixed here : https://youtu.be/sLGHK4J17Xc
I am having the same problem. My personal license does not work.
spend 2 hours just trying to activate. Getting Invalid refresh token error.
Honestly why do you make it so complicated onboarding??? waste of space
Hi Marius,
Thank you for leaving the comment.
I am sorry to hear about your issue. Can you send more details about your issue to support@unity3d.com ? so that I can look into this further.
Let us know once you submit the request and got a ticket number.
Solved Here : https://youtu.be/sLGHK4J17Xc
Every time I try to add the Personal License, Unity just tells me to log in and connect to the internet. I am already connected and logged in. This is in the beta hub though, I will try it in a non-beta version.
Sorry, disregard my comment above. I just updated the hub and now everything works fine. It even says on the unity changelog that beta.4 fixes licensing issues.
Activate with license request does not work, get a free personal license doesn't work too, I can't use the unity just because of the license, what is your problem why nothing works?
Hi Qmzixy,
Thanks for reaching out.
I'm sorry to hear your question. If you still have this problem, please contact us via support@unity3d.com. I will try my best to ask you to solve your problem. Thank you.
Check log:
"C:\Users\[yourname]\AppData\Roaming\UnityHub\logs\info-log.json"
have something like that:
"'Invalid license file: C:\\\\ProgramData\\\\Unity\\\\Unity_lic.ulf, reason: Entitlement group is expired."
remove that "Unity_lic.ulf" file and replace it with the file from "Activate with license request" in the same name.
The problem was resolved.
(I installed Unity hub a few month ago, and uninstall. After that, when I installed Unity hub again, the problem happened.
had very similar issue recently , just now managed to fix , by getting help from Unity. This is what i had to do:
I can't seem to get a license. Every time I try, the Unity Licensing Client rejects my password. Is it that I need a different kind of password?
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