Symptoms:
- I have not received my verification, confirmation, or password reset email.
- My verification/confirmation/password reset email never arrives.
- I can not confirm my email address or reset my password.
- I have not received a verification code email.
Cause:
Not receiving your verification, confirmation, or password reset emails can sometimes occur due to one or more of these factors:
- The email has been sent to the spam or promotions folder instead of your inbox.
- You have signed up with a different email address.
- The email address was not spelled correctly.
- The email has not been sent immediately from our mailing server.
- The system has not completed the request and you will need to reattempt the process.
Resolution:
If you cannot see your verification, confirmation or password reset email, this could be for several reasons relating to your email account's inbox. There are several likely causes to investigate. These include email quota issues, your DNS settings, and your email client settings.
Make sure that all '@unity3d.com' email addresses have been safelisted. This tells your email client that you know this sender and trust them.
Also, check your spam and promotions folders and junk mail. It is not uncommon for emails to be forwarded to these folders instead of your inbox folder.
Ensure you enter the email address correctly, and your confirmation or password reset email will be resent to your inbox folder.
If the issue persists, please try using a different browser.
Please note: The system can get quite busy, so if you do not receive the email immediately, you may need to wait a short time for it to be processed. |
Troubleshooting:
If you continue to experience issues, please contact Customer Experience.
More information:
I am unable to confirm my email address/reset my password.
I have been asked to enter a verification code while trying to log in. Why did I receive this?