Symptoms:
- I tried to delete my Unity account, but it said I couldn't do so without contacting support.
- I need to delete my account, but something is blocking it.
Cause:
In some cases, Unity has a business reason that prevents us from being able to delete your account immediately.
The possible reasons that would prevent account deletion can include:
- The account still has an active subscription, such as Plus, Pro, or Teams Advanced.
- Having a subscription that is still within its initial 12-month commitment period.
- An outstanding balance, billing discrepancy, or open asset order that needs to be settled.
- Being an Asset Store or Ads publisher and having a remaining balance that needs to be paid.
If any of the above scenarios apply when requesting to delete your account, a dialogue box appears for you to refer to our Unity Privacy team (DPO), with an option to include a message that is sent to dpo@unity3d.com.
Resolution:
When the DPO team receives your request to delete your account, they will contact Unity Support to inform us that you want to delete the account but an outstanding issue has prevented this (i.e. as detailed above).
Unity Support will then contact you directly to resolve the outstanding block, and the team will work with you to delete the account.