Symptoms:
- I am trying to log in to my Unity ID but I'm not receiving my Two Factor Authentication (TFA) code.
- I am experiencing a delay in TFA codes and I don't know why.
- I am unable to retrieve my TFA code as it is going to an old device.
Cause:
There are a number of reasons why there could be a delay in receiving your code. Here are some examples.
- What causes this varies from handset to handset. If a mobile device is located outside a network's coverage area or in a spot where the network signal is blocked such as in a mountainous region, a delay in transmission may occur. In urban areas, tall buildings can also cause transmission issues. Being in an old building with poor cell phone reception is another possible culprit.
- The most obvious cause is a device that has been turned off, but a weak or uncharged battery may also negatively impact message delivery.
- A text sender and receiver using different networks may have a greater chance of experiencing texting delays than those using the same network, because of communication between networks, or the carrier prioritizing their own traffic.
- Texting during periods of heavy network use impacts text delivery speed. Periods of increased traffic may create congestion on the local network and delay the arrival of messages to the handset.
Resolution:
Whilst there are a number of reasons which could be delaying the message, this is out of our control.
You can only combat this by making sure your device is charged sufficiently.
If you do not have access to the device linked to your account, please get in contact with our Customer Service team here.
More Information:
TFA is not to be confused with the Security Notification Codes which are sent via email when our system flags a login attempt as risky. More information on this can be found in the article ‘I have been asked to enter a verification code while trying to log in. Why did I receive this?’.
How do I enable Two Factor Authentication on my account?
I have been asked to enter a verification code while trying to logging In. Why did I receive this?
Comments
3 comments
I'm unable to simply download the latest version of unity
Hello Henry.
Derek here from Unity Customer Service. Thanks for reaching out to us.
I'm sorry to hear that you are receiving an error when trying to download the latest version of the editor.
In this instance, we will require more details on the error that is happening as it occurs. Can you please reach out to support@unity3d.com and provide us with a step by step process of what is happening with accompanying screenshots?
This way we can investigate further.
I've created a ticket on your behalf. If you respond to my message there we can get started on investigating this issue.
I'll look forward to hearing from you shortly.
All the best.
Derek
Hi, I had this problem today,
I want to setup my Payout Profile via Unity ID. When I try to click the menu, the system tell me to activate my TFA for my account, and I starting to setup my account.
After Setup my phone number (Indonesia +62) and ask the system to send the code, I never receive any code on my phone. My laptop and mobile had a good connection during that time. I try 10x to request the code but I never receive the code until I looking at this page.
Is there any issue with TFA in Indonesia provider? I except delay information but after waiting for about 1 hour I never receive any message on my phone about the code
Thank you for the reply all,
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