Symptoms:
- I received an invoice from Unity for a pay-as-you-go service, such as Unity Gaming Services (UGS), and DevOps, with an amount less than a dollar.
- I'm unsure if I need to pay this small invoice amount.
Cause:
Unity's billing system generates invoices automatically based on usage of your pay-as-you-go subscriptions, no matter the total billed amount.
Resolution:
Yes, it is important to pay for the invoice, even if the amount is less than a dollar. Unity's billing terms require that all issued invoices be settled, regardless of their size. This helps maintain account accuracy and ensures uninterrupted service.
Usually, the invoices for these pay-as-you-go subscriptions will be automatically charged to the registered payment method in your account.
However, if the payment failed for some reason, please refer to this article to update your payment method: Overdue invoice on the Cloud Dashboard
Additionally, you can check the payment status via your Unity Cloud > Administration > Transaction history.
If you have any difficulties or need further assistance, please contact the Customer Experience team via this form including your invoice number and details.
More information:
How do I change the payment method in Unity Cloud?